ipsec快还是ikev2快,ipsec和ikev2哪个好

2022年 10月 20日 发表评论
腾讯云618会场:点此直达 阿里云618会场:点此直达
免费/便宜/高性价比服务器汇总入口(已更新):点此直达

------------------IKEV2-----------------------------
1.基本上网配置
interfaceGigabitEthernet0 ---------配置外网口,定义接口
nameif outside
security-level 0
ip address 101.1.1.100 255.255.255.0
interfaceGigabitEthernet1 -----------配置内网扣,定义接口
nameif inside
security-level 100
ip address 192.168.1.1 255.255.255.0
2、定义object
object network inside_network -------------需要上互联网的sub
subnet 192.168.1.0 255.255.255.0
object network local_network ----------定义本端网络
subnet 192.168.1.0 255.255.255.0
object network remote_network---------定义远端网络
subnet 172.16.1.0 255.255.255.0
3、定义ACL
access-list 100 extended permit ip any any ------定义any any互联网ACL
access-list 110 extended permit ip object local_network object remote_network -----定义***感兴趣流量
4、配置NAT
objectnetwork inside_network -------配置PAT
nat (inside,outside) dynamic interface
access-group 100 in interface inside -------将ACL 100应用到inside接口
nat (inside,outside) source static local_network local_network destination static remote_network remote_network /拒绝流量被NAT
5、配置默认路由
route outside 0.0.0.0 0.0.0.0 101.1.1.1
6、配置IPSEC
6.1 IPSEC第一阶段ike配置
crypto ikev2 policy 10 ---------定义ikev2策略
encryption aes-256
integrity sha256 md5
group 2
prf sha256 md5
lifetime seconds 86400
tunnel-group 201.1.1.100 type ipsec-l2l ------定义隧道,类型为ipsec-l2l
tunnel-group 201.1.1.100 ipsec-attributes
ikev2 remote-authentication pre-shared-key cisco ------配置预共享密钥为cisco
ikev2 local-authentication pre-shared-key cisco
6.2 IPSEC第二阶段ipsec配置
crypto ipsec ikev2 ipsec-proposal cisco -------定义ipsec转换集
protocol esp encryption aes-256
protocol esp integrity md5
6.3 定义map映射绑定策略与ipsec转换集
crypto map cisco 10 match address 110 -----定义crypto map,绑定感兴趣流ACL 110
crypto map cisco 10 set peer 201.1.1.100-------指定peer对等体公网IP地址
crypto map cisco 10 set ikev2 ipsec-proposal cisco ------调用刚才创建的ipsec转换集
cryptomap cisco interface outside -------将map应用到outside接口
6.4 开启ikev2策略到outside接口
crypto ikev2 enable outside

05239285

腾讯云618活动:点此领取】8888元代金券,附云服务器价格表,2核2G4M轻量应用服务器99元1年,新老用户都可以买,可以享受1次续费99元一年、135元15个月、三年560元,MySQL云数据库59元1年起,2核2G3M配置82元1年,2核4G5M配置188元一年、3年900元,4核8G12M轻量服务器880元15个月,8核16G配置1890元15个月,更多16核32G28M带宽和云服务器CVM标准型S5、GPU服务器、CVM标准型SA2租用优惠价格如下,可以 点此进入最新活动页 查看当前最新的优惠券和活动信息。 腾讯云首购便宜续费贵,点击前往 【爆品专区】选择3年/5年,免得续费贵;首购便宜升级贵,建议 点击 选择8核16G/16核32G配置高的服务器。 阿里云618活动:点击领取】5亿上云补贴和2088元满减代金券,阿里云服务器租用费用618活动最新价格表【点击了解】,最便宜轻量应用服务器2核2G3M带宽82元1年,ECS云服务器2核2G3M带宽99元一年,ECS u1实例2核4G5M带宽优惠价格199元一年,香港30M带宽轻量服务器24元1个月、288元一年,4核8G服务器706元一年,ECS云服务器4核16G10M带宽30元1个月、90元3个月,云服务器8核32G10M带宽109元1个月、327元3个月。 腾讯云老用户享新人优惠的方法:用Qq登录、1人可注册3个新账号/用家人朋友的身份注册新号(点击注册新账号)。
小咸鱼

发表评论

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: